Service Management customer notifications for new tickets have a different sender than the project name
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When customers create tickets using the Customer Portal or through email, they receive a notification email having a Sender different than the Customer Portal name.
The Customer Portal name was configured via Project settings > Portal settings > Name, however this is not shown as Sender of the emails for new issue creation.
Diagnosis
The issue only occurs when using Office 365 / MS Exchange as an outgoing mail server, and does not occur with other servers such as GMAIL.
atlassian-jira-outgoing-mail.log shows that Jira correctly sent the notification emails having FromName='<project_name>':
2021-07-18 01:20:06,018+0000 DEBUG [] Sending mailitem To='abc@atlassian.com' Subject='PROJ-12345 test' From='null' FromName='JIRA Helpdesk' Cc='null' Bcc='null' ReplyTo='xyz@atlassian.com' InReplyTo='null' MimeType='text/plain' Encoding='UTF-8' Multipart='null' MessageId='null' ExcludeSubjectPrefix=true' anonymous Mail Queue Service Message was sent with Message-Id <JIRA.107511.1625743405000.5957.1625743505880@Atlassian.JIRA>
Cause
Since Jira sent the emails with the correct "From" address as the project name for the ticket creation event, it means that the sender is being overwritten by another system.
This behavior was noticed for Office 365 / MS Exchange server which can overwrite the email address of the "From" header to the account that sent it, rather than what was specified.
It is also possible that the email system's addressing book is overwriting the configurations set by JIRA.
Solution
Please reach out to your mail server administrator and ask to check if the email address configured in Jira > System > Outgoing mail is present in the address book or if there is any other reason for which the Sender is overwritten.