Short wait time when receiving Jira Cloud email notifications


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

 

Summary


You may notice a 3 to 10 minutes wait when receiving email notifications from when an event occurred in Jira due to email batching.

Environment


Jira Cloud

Diagnosis

From 3 to 10 min wait when receiving JIRA Cloud email notifications.

Cause

In order to reduce the number of emails you receive, Jira Cloud will group several updates into a single email by default, instead of sending individual emails for each update.

Critical updates (like when you’re mentioned, or an issue is assigned to you) are always sent immediately.

For the same recipient and issue, the grouping window uses an idle time and a max window time to determine when the email notification will be sent.

Unless you have selected a custom grouping window, Jira waits 3 minutes (idle time) after a change to an issue is made. If no additional changes are received, Jira sends a notification for the change. If an additional change is made before the idle time lapses, Jira resets the 3-minute idle time and listens for additional changes. The process repeats until the 3-minute idle time lapses or a maximum window time (10 minutes) is reached.

The most noticeable impact to users will be:

  • A short wait in receiving emails (between 3 and 10 minutes)

  • Lower volume of emails received, as events are grouped together (approximately 30% on average)

Note that there are some exceptions when email notifications are not batched:

If you experience a longer wait time when receiving email notifications, please contact Atlassian Support.

Last modified on Jul 29, 2024

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