SLA does not Work even though it matches the Start/Stop Conditions
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
In some cases, SLA is somehow not Start or Stop even though the Ticket has been moved to the Status where the condition match the Start or Stop Conditions.
Diagnosis
Check the Workflow Transition to the affected Status whether the "Post Functions" has any "Events" set. Below is an example of a Transition with "Generic Event" set which is one of Jira Issue Event. These kinds of events should not be missing from the Post Functions.

Cause
It appears that due to the Missing Events that is usually stated in Workflow Post Function Transition, the SLA would not work.
Solution
Resolution
Add the Post Function Issue Event back to the Transition.
Note
It is not possible by default to remove the Issue Event in a Transition Post Function
Jira Issue Event actually required for any other feature beside SLA such as Notification hence it is only editable, not deletable.
Was this helpful?