Slowness in Jira email notifications

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Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Summary

Slowness in Jira email notifications caused by the Scheduler Tasks busy with Version & Component Sync activities.


Diagnosis

  • 5-15 min delay in JIRA email notifications; 
  • All notification events are affected;
  • We can observe the mail queue increasing with nearly 400 mails to be sent and then start sending emails;
  • Jira outgoing mail is working properly and a test email using the same SMTP server was fast sent and received;
  • Emails are being sent (SMTP server is working);
  • Batch notification is disabled;
  • A manual flush of notifications works.


Environment

  • Jira Software 7.x or 8.x.
  • Version and Component Sync for Atlassian Jira app version 2.7.2 or earlier.


Cause

Some of the Scheduler tasks (Caesium 1-1 to Caesium 1-4) are held by plugin Version & Component Sync for Jira.


Workaround

  • Disable the plugin Version & Component Sync for Jira.
  • Manually Flush the mail queue
    • This will prevent any loss in notifications
  • Restart Jira Server;
  • Monitor the notification queue if it is back to the normal delay.


Solution

Issue fixed on version 2.7.2 of Version & Component Sync (VCS) which is now available on the Atlassian Marketplace.


Last modified on Oct 28, 2020

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