SOAP Issue Created with the Wrong Reporter

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Symptoms

When creating an issue via SOAP service, the reporter value doesn't get updated even though it has been defined in the SOAP client. Hence, when the issue is created, the reporter will change to the current user.

Cause

The reporter field is not included in the create issue page. The SOAP service acts like the operation in the web interface. If the field is not included on the screen, it will set the current user as the reporter.

Resolution

Add the reporter field to the appropriate screen. See Configuring Fields and Screens.

Last modified on Feb 26, 2016

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