Some approvers cannot approve a Jira Service Management request which is in an approval status

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

Some approvers cannot approve a Jira Service Management request which is in approval status. When they receive the approval notification and click on the Approve button, they see either of the 2 errors below in the UI after logging into the Customer Portal:

  • Example of error 1

    You do not have permission to view this request

  • Example of error 2

    You don't have approve permission


Environment

Jira Service Management (Server/Data Center) 4.0.0 and any higher version.

Diagnosis

  • The approver who clicked on the approve button from the notification email has 2 Jira accounts using the same email address (which can be verified by going to the page ⚙ > User Management > Users), for example:
  • The approver used the 2nd Jira account to log into the customer portal (account julien6@test.com in the example above)
  • The user that was set as the approver of the request is not the same account and is in fact the 1st Jira account (account julien6 in the example above)

Cause

Email addresses are not unique in Jira, therefore 2 different users can be created with the same email address. In the example above, there were 2 different users sharing the same email address, therefore both users received the same approval notification even though this notification was only meant for one of these users. As a result, if the wrong user clicks on the approve (or decline) link in the email, this user will not be allowed to approve the request since this notification was not meant for them, and one of the 2 error mentioned in the summary of this article will be displayed in the UI:

  • the 1st error You do not have permission to view this request will be displayed in the UI in case the user who clicked on the approve button:
    • does not have access to the request at all (by not being the reporter, nor a request participant, nor a member of the organization the request was shared with)
  • the 2nd error You don't have approve permission will be displayed in the UI in case there user who clicked on the approve button:
    • has access to the request (by being the reporter, a request participant, or a member of the organization the request was shared with)
    • but is not the user who was set as the approver of the request

Solution

Ensure that the user who clicked on the approve button is the actual user who was set as the approver of the request, especially in the case where multiple users might share the same email address in Jira.


Last modified on Apr 17, 2023

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