Some issues marked as Done are missing from an Advanced Roadmaps plan

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

Some issues that are in a DONE status (status which category is DONE) are missing an advanced roadmap plan, while they are visible from the board linked to the plan.

For example:

  • Here, the SCRUM-14 issue is in the Approved status, which belongs to the "DONE" category (green-colored status):
  • This issue is shown in the Board that is linked to the plan.
  • However, this issue is missing from the plan.

Environment

Jira Software Server/Data Center on any version from 8.0.0

Diagnosis

  • The issue that is missing does not have a resolution set (the resolution field is set to unresolved)
  • A way to find all the issues visible in the board that are missing from the plan is to use the following JQL query

    <Board_filter_JQL_Query> AND statusCategory = done AND resolutiondate is null

  • For the problematic status (Approved status in the example above), the workflow is configured to set the resolution field when issues are transitioned to this status:

Cause

As mentioned in the Advanced Road Map Viewing work documentation:

Any issues that have been marked as done in Jira Software, that don't have a resolution set, will not be included in the plan.

The reason for this is that is because "Jira Software uses the Resolution field to define completed issues.", and without a "Resolution date" being set, ARJ can't properly evaluate the cut-off threshold configured in the Plan as mentioned in Troubleshoot missing issues in Advanced Roadmaps.

 
Therefore, if an issue is in a status that is categorized as "Done" while the resolution field is not set, such an issue will not appear in the plan view, even if it will still appear in the board view. This behavior is expected by design.

There is an open feature request meant to change this behavior, which is tracked in the public ticket linked below:
JSWSERVER-25116 - Getting issue details... STATUS

Solution

Solution 1 - Adding a post function to set the 'Resolution' field

Modify the workflow transition that is transitioning to the completed status to automatically set the resolution field to a non-empty value by using the post-function Update Issue Field, and make sure to publish the workflow change:

Post-function details:

Post-function placement:

This workflow change will ensure that the next time an issue is transitioned to that Done status, the resolution field will be set and therefore the issue will show in the plan view.

For issues that have already been transitioned to that status prior to the workflow change, you can transition these issues to a different status, and then transition them back to that status in order to set their resolution field.

Solution 2 - Adding a Dark Feature to allow 'Unresolved' issues to be shown on Plans

If modifying the workflow is not an option, you can instead enable a dark feature to allow the plan view to show issues in a Done status while not having the resolution set.

Here are the steps to enable this dark feature:

  1. Login as a Jira Admin
  2. Go to the following URL
    '<Jira_BASE_URL>/secure/SiteDarkFeatures!default.jspa'
  3. Add the following dark feature

    com.atlassian.portfolio.issueloading.includeUnresolvedCompleted
  4. Make sure that the dark feature is listed on the page, as shown in the screenshot below:


Last modified on Dec 28, 2023

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