SoyTofuException encountered attempting to reindex after upgrading to Jira 8.5

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

A SoyTofuException is encountered when attempting to re-index after upgrading to Jira 8.5 and later from an earlier version.

Environment

Jira 8.5 and later

Diagnosis

When attempting to complete a Background re-index or a Full re-index, you encounter a SoyTofuException similar to the example below.

Technical details
Log's referral number: #-#-#-#

Cause
Referer URL: https://jira.baseurl.com/secure/admin/IndexAdmin.jspa

com.google.template.soy.tofu.SoyTofuException: When evaluating "'IndexReIndex!reindex.jspa?atl_token=' + $atlToken + '&indexingStrategy=' + $indexingStrategy": Attempted to coerce undefined value into a string.
com.google.template.soy.tofu.SoyTofuException: When evaluating "'IndexReIndex!reindex.jspa?atl_token=' + $atlToken + '&indexingStrategy=' + $indexingStrategy": Attempted to coerce undefined value into a string.
at JIRA.Templates.Admin.Index.buttonContainer(confirm-reindex.soy:65) [?:?]
at JIRA.Templates.Admin.Index.confirmReindex(Unknown Source) [?:?]
at com.google.template.soy.tofu.internal.BaseTofu.renderMainHelper(BaseTofu.java:369) [?:?]
at com.google.template.soy.tofu.internal.BaseTofu.renderMain(BaseTofu.java:322) [?:?]
at com.google.template.soy.tofu.internal.BaseTofu.access$100(BaseTofu.java:66) [?:?]
at com.google.template.soy.tofu.internal.BaseTofu$RendererImpl.render(BaseTofu.java:476) [?:?]
at com.atlassian.soy.impl.DefaultSoyManager.render(DefaultSoyManager.java:154) [?:?]


Cause

Cause 1

Custom Javascript introduced via the announcement banner can result in this type of failure. 


Cause 2

Running third-party apps that have not been updated to a version that is compatible with the version of Jira that is installed can result in this type of failure. 

Solution

Solution 1

  • Choose Administration (   ) >System
  • Select User Interface > Announcement banner in the System panel below.
  • Save the current text from the Announcement field to a text file.
  • Temporarily remove all text from the Announcement field.
  • Test to see if you can reproduce the re-index failure.

Solution 2

  • Visit Administration (    ) > Manage Apps and choose Manage Apps under ATLASSIAN MARKETPLACE.
  • Update all third-party apps to a version that is compatible with the version of Jira you have installed. 


Still having a re-index failure? 

DEBUG logs will help to better understand the nature of the re-index failure during the next attempt.

Please enable Indexing DEBUG logs using the:

  1. Navigate to Administration (    ) System > Logging and profiling
  2. Scroll down to the "Configure logging level for another package." line and click "Configure"
  3. Add these packages at the DEBUG level: 
    1. com.atlassian.jira.index 
    2. com.atlassian.jira.issue.index

      Note: The DEBUG logs can be disabled after the data has been collected.

  4. Collect a support zip
  5. Open a case with Atlassian Support.  


Last modified on Oct 3, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.