StatusPage Add-on integration is not working in Jira Service Management

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The customer web portal channel in JSM does not display any visible links to the Status Update or Incidents from the StatusPage.

Environment

The issue may occur in any setup where one Jira instance makes an HTTP\s request to a StatusPage server.

Diagnosis

When a Jira instance makes an HTTP\S request to a remote StatusPage server to retrieve the incident status, the request fails with messages similar to the following:

{"message":"java.net.SocketException: Connection reset"}


Analysing the HAR file, we could observe the referrer URL '<JIRA_BASE_URL>/servicedesk/customer/portal/1' followed by the link address '<JIRA_BASE_URL>/rest/statuspage/1.0/config/project/status_page/10003' is unable to load or failing with the following error:

{"message":"org.apache.http.conn.ConnectTimeoutException: Connect to 88xw9l2t6thr.statuspage.io:443 [88xw9l2t6thr.statuspage.io/13.236.8.149] failed: connect timed out"}

Cause

In order to retrieve incidents from the StatusPage, Jira will send an HTTP outbound request over port 443, which is blocked by the firewall:

root@jiraapp:~# nc -vnz -w 1 13.236.8.149 443
nc: connect to 13.236.8.149 port 443 (tcp) timed out: Operation now in progress
root@jiraapp:~#


Solution

Allow outbound connections from Jira application server to the StatusPage server over port 443. A successful transaction will look like this:

root@jiraapp:~# nc -vnz -w 1 13.236.8.149 443
Connection to 13.236.8.149 443 port [tcp/*] succeeded!
root@jiraapp:~#

After successfully establishing communication, a message will be displayed on the web portal channel in JSM to inform your customers about the incident:


Last modified on Apr 26, 2023

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