Stuck loading on the splash screen when opening the JIRA plug-in within excel

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Jira add-on does not load in MS Excel app. A white screen shows up when trying to open Jira add-on in MS Excel.

Environment

Jira Cloud

MS Excel

Diagnosis

Looking into HAR Logs, following error is seen:

"strServiceExceptionMessage": "AADSTS90094: An administrator of XXXXXX has set a policy that prevents you from granting Jira Cloud for Excel the permissions it is requesting. Contact an administrator of Coventry Building Society who can grant permissions to this application on your behalf.",
                "strTraceId": "XXXXXXXXXXXXXX",
                "iErrorCode": 90094,
                "strAppRootDomain": "jira-spreadsheets.services.atlassian.com",
                "iHttpErrorCode": 400,
                "iViewId": 2,
               
 "urlConsentSwitchUser": "https://login.microsoftonline.com/common/reprocess?ctx=xxxxxx"
"urlCancel": "https://jira-spreadsheets.services.atlassian.com/v2/auth/flow?error=access_denied\u0026error_subcode=cancel\u0026state=XXXXXXX"
                "strTimestamp": "XXXXXXX",
                "urlAppLogo": "https://secure.aadcdn.microsoftonline-p.com/XXXXXXX",
                "fShowIssuerHintErrorStrings": true,
                "strAppDisplayName": "Jira Cloud for Excel", 


Cause

The issue happens because of Mircrosoft policy applied on MS excel. This exception is discussed in MS document as well:

Solution

  • AADSTS90094: Jira Cloud for Excel needs permission to access resources in your organization that only an admin can grant. Ask an MS Excel admin to grant permission to this app before you can use it.



Last modified on Jul 31, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.