SUGAR CRM Integration with JIRA software is not displaying any reporter or assignee.

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While using the integration between Jira and Sugar CRM, it might be possible that while creating some Sugar CRM reports, some information from Jira is not showing as expected.

Diagnosis

Looking at the atlassian-jira.log file it should be possible to see the following error related to the /rest/api/2/user/assignable/multiProjectSearch API endpoint.

2022-05-06 11:44:24,179-0500 http-nio-8080-exec-51 url: /rest/api/2/user/assignable/multiProjectSearch; user: xxxxxx WARN xxxxxxx 704x16451477x1 ac8mtd xxxxxxxx /rest/api/2/user/assignable/multiProjectSearch [c.a.jira.permission.DefaultIssueUserSearchManager] Requested top N=150 and is greater then max top allowed: 100. Enable trace logging to see stack trace.

Environment

<= 8.20.7

Cause

This is related to this known JSWSERVER-21156 - Getting issue details... STATUS BUG related to this Find bulk assignable users API endpoint.

Solution

Please kindly refer to the JSWSERVER-21156 - Getting issue details... STATUS description and workarounds.

Sugar CRM report support

Please keep in mind that providing support for Sugar CRM is out of our scope and it's not included in our Atlassian Support Offerings



Last modified on Jun 8, 2022

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