The customer notification to be sent only to Requester and Request Participants when an Organization is added during issue creation

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

You wish to configure the customer notification to be only sent to Requester and Request Participants when an Organization is added during issue creation from the portal.

Environment

Jira Service Manangement Cloud 

Diagnosis

While creating a request, the customer selects an Organization, or an Organization is auto-selected based on Requests automatically shared with the organization. As a result, the request notification is triggered to all users under that Organization.

Cause

The Organization Added notification is enabled in the Service Desk project: Project Settings > Customer Notification > Organization Added. This would trigger the email notification to all members of the Organization when a request is shared with the Organisation.

 

Solution

You can disable the Email Notification for the users under the Organization then, the Project Admin can disable Organisation Added Customer Notification under Service Project(Project Settings > Customer Notification). Please note, this will disable email notifications every time a ticket is shared with Organization within that project.

  • If a ticket notification needs to be shared with a few people under the Organization, in that scenario, those users can be added as Request Participants within the concerned request. 

We are tracking an open feature request with our product team:

JSDCLOUD-4543 - Ability to Disable Notification Within Organisation



Last modified on Jan 21, 2025

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