The email request received on Jira Service Desk displays the content in a non-readable format

 

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

   

Summary

When an email request is received in Chinese, Japanese, Taiwanese, or Russian the data is displayed in an unreadable format on the request created in Jira.

Cause

  • The issue is occurring because the email client used by the help seeker(i.e. the help seeker who sent the form to the helpdesk) is not setting the charset in the content type. The current value is Content-Type: text/plain whereas it should ideally be Content-Type: text/plain; charset=utf-8 (if they want to send emails containing languages like Japanese).
  • Also, the email clients such as  Outlook and Apple Mail are able to correctly render the Japanese text even when the charset info is missing could be because they might have handled this on their side(i.e. they would be deviating from the RFC-2046 and instead of setting the default charset to UTF-8 while reading the email, i.e. Atlassian's email parser is adhering to the standards specified by RFC-2046, but Apple Mail client and outlook(and perhaps some other mail clients) are deviating from the RFC and adding the charset header into the emails before reading/parsing them.

Solution

  • Email clients allow setting the default charset for emails, if that is allowed by the email client being used, then setting it to UTF-8. For example, the charset for outlook can be set by following the below article. 


Last modified on May 22, 2022

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