The error "We're having trouble communicating with the application" is thrown when trying to create a knowledge base article from a Jira Service Management ticket
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When trying to create a Confluence KB article from a Jira Service Management issue, an error occurs in the 'create an article' pop-up dialog:
We're having trouble communicating with the application. Wait a minute, then try again
Environment
Any Jira Service Management (JSM) Server/Data Center version with any Confluence Server/Data Center version.
Diagnosis
- The application link between the JSM application and the Confluence application is already using the the recommended authentication type Oauth (with impersonation) on both JSM and Confluence side
The following error might be found in the file atlassian-jira
.log
2017-04-08 16:36:13,750 http-nio-8080-exec-10 ERROR admin 996x1664x1 1akpo00 192.168.1.100:8080,192.168.1.101 /rest/servicedesk/1/servicedesk/SD/kb/create-draft [c.a.s.i.api.applink.BaseAppLinkResponseHandler] Applink request has returned an error with status code 400: {"errorCode":400,"errorType":"PERMISSION:USER:CREATE:PAGE","errorData":"MYWIKI","errorMessage":"No permission to create pages in space MYWIKI."}
Cause
As seen from the logs, the cause of the error is lack of permission to create a page in the Confluence space.
Resolution
The Jira Service Management user or Agent needs to be granted Pages > Add permission in the relevant Confluence space. For more information on how to manage Confluence Space permission, please refer to the documentation Space Permissions Overview.