The Jira server could not be contacted. This may be a temporary glitch or the server may be down

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

You are trying to search for projects or issues using the Advanced Issue search and you face the error:

The Jira server could not be contacted. This may be a temporary glitch or the server may be down


Environment

  • JIRA Software (including JIRA Agile)

Diagnosis

  1. Record a HAR trace file, as per the following Atlassian documentation Generating HAR files and analyzing web requests
  2. Search for a POST method for the URL: https://<YourInstance>.atlassian.net/secure/QueryComponent!Default.jspa

The response methods will show the following errors:

Request URL:https://<YourInstance>.atlassian.net/secure/QueryComponent!Default.jspa
Request Method:POST
Status Code:net::ERR_BLOCKED_BY_CLIENT
Remote Address::80

OR

Request URL:https://<YourInstance>.atlassian.net/secure/QueryComponent!Default.jspa
Request Method:POST
Status Code:net::ERR_HTTP2_PROTOCOL_ERROR
Remote Address::80

OR

Request URL:https://<YourInstance>.atlassian.net/secure/QueryComponent!Default.jspa
Request Method:POST
Status Code:net::ERR_ABORTED
Remote Address::80

Cause

QueryComponent.jspa is responsible for running the JQL query when the user searches for issues, using a filter or the advanced issue search.

It may represent a problem with browser configuration or some error with a conflicting extension or a network issue.

Below are the most common root causes for this issue:

  • Cookies, Browser history, or Corrupt Cache
  • Network issues on the machine
  • Browser Extensions
  • The browser is running a deprecated version

Solution

In order to fix this issue, please proceed with the following steps:

  1. Clear DNS Cache on the affected computed
  2. Clear Cookies and Temporary Files from the browser
  3. Update your browser to the latest version available
  4. Check extensions from possible blocks (mainly AdBlock or similar)

These actions usually solve this kind of issue.

If this issue is appearing to all users, you should check with your network/infrastructure team if some firewall rule is blocking the /secure/QueryComponent!Default.jspa

Last modified on Mar 15, 2023

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