The Jira Service Management request detail page freezes after a request is created when using Firefox or Safari

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

   

Summary

When using Jira Service Management, after creating a request on the Customer Portal, the request detail view crashes, refusing to load. The problem occurs:

  • only on specific browser (Firefox, Safari), but not on other browsers (Chrome, Microsoft Edge)
  • in all Service Management projects
  • for all users, Jira administrators, and customers

Environment

Jira Service Mangement 4.x and higher.

Diagnosis

  • When creating a request from the Customer Portal on Firefox, the following happens:
    • After a few seconds, Firefox shows the message "A web page is slowing down your browser", and the user gets an option to either "wait" or "stop" the problematic page
    • After clicking on "stop", the request detail page loads as expected
  • When collecting the output from the Browser Development tool console, we might see that some scripts were terminated:

    Script terminated by timeout at:
    kl@<JIRA_BASE_URL>/s/441c0047657a42cf3a830c9bb0cb14ee-CDN/sihfre/813013/1kkn3r9/9f134e607850b9feac1a2833b9295c84/_/download/contextbatch/js/jira.webresources:almond,customerportal,servicedesk.portal,com.atlassian.analytics.analytics-client:js-events/batch.js?locale=en-US:1848:98061
    ll@<JIRA_BASE_URL>/s/441c0047657a42cf3a830c9bb0cb14ee-CDN/sihfre/813013/1kkn3r9/9f134e607850b9feac1a2833b9295c84/_/download/contextbatch/js/jira.webresources:almond,customerportal,servicedesk.portal,com.atlassian.analytics.analytics-client:js-events/batch.js?locale=en-US:1848:94207
    Ho/<@<JIRA_BASE_URL>/s/441c0047657a42cf3a830c9bb0cb14ee-CDN/sihfre/813013/1kkn3r9/9f134e607850b9feac1a2833b9295c84/_/download/contextbatch/js/jira.webresources:almond,customerportal,servicedesk.portal,com.atlassian.analytics.analytics-client:js-events/batch.js?locale=en-US:1848:45318
    
    ...
  • When checking the add-ons installed in the Jira application, either via the page ⚙ > Manage Apps > Manage Apps, or via the application.xml file from the support zip, we can see that the add-on Extension for Jira Service Desk is installed and is on a version lower than 6.13.2, for example:

       <plugin>
          <key>com.intenso.jira.plugins.jsd-extender</key>
          <name>Extension for Jira Service Desk</name>
          <version>6.12.5</version>
          <vendor>Deviniti</vendor>
          <status>ENABLED</status>
          <vendor-url>www.deviniti.com</vendor-url>
          <framework-version>2</framework-version>
          <bundled>User installed</bundled>
        </plugin>
  • If the add-on Extension for Jira Service Desk is disabled from ⚙ > Manage Apps > Manage Apps, the issue is no longer replicable

Cause

The add-on Extension for Jira Service Management is known to cause slowness issue on some browsers like Safari or Chrome and the issue was fixed on the version 6.13.2, as per add-on version history.

Solution

Upgrade the add-on Extension for Jira Service Management from the page ⚙ > Manage Apps > Manage Apps to the version 6.13.2 or any higher version.



Last modified on Sep 22, 2022

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