The Knowledge base search bar is missing from the Service Management Customer Portal
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After connecting Service Management to Confluence and setting up a knowledge base in a project in Project Settings > Knowledge base, customers should be able to search for Confluence articles in two ways from the Customer Portal
- The Help Center Home page
- Project specific portals
However, in some cases, the search bar might be missing:
- The Help Center Home page
- Project specific portals
Environment
Any Jira Service Management Server/Data Center version 3.x and 4.x with an application link to any Confluence Server/Data Center version.
Diagnosis
- Check if the 3rd party add-on HelpCenter Corrector is installed in your Jira Service Management instance (via the page ⚙ > Manage Apps > Manage Apps)
- If this add-on is installed, go to the page ⚙ > Manage App > HelpCenter Corrector, and check if any of the 2 options below is ticked:
- Hide HelpCenter Search Bar
- Hide Customer Portal Search Bar
- See screenshot below for reference:
- If any of these 2 options is ticked, then this KB article is relevant
Cause
The 3rd party add-on HelpCenter Corrector has the option to hide the knowledge base search bar from either the Help Center or project specific portals.
Solution
Untick the 2 options Hide HelpCenter Search and Bar Hide Customer Portal Search Bar.