The search index does not update when users create an issue

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The search index does not update when users create an issue, even after several hours. 

Diagnosis

  • A newly created ticket does not show up in any queries. 
  • When re-indexing manually, the newly created issue starts showing up in queries normally.
  • Missing IssueReindexFunction post function in the issue's affected workflow


Cause

Legacy versions of JIRA did not have the IssueReindexFunction post function available for workflows.

Workaround

Add the "Re-Index Issue" post function to the Create Issue transition of the affected workflow

If you need to find all affected workflows, run the following SELECT against JIRA's database:


select * from jiraworkflows where descriptor not like '%IssueReindexFunction%';


This problem is also discussed in  JRASERVER-32508 - Getting issue details... STATUS

Last modified on Jul 12, 2018

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