The user picker field on the customer portal does not work

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Customers are unable to use the user picker field on the Customer Portal. The user picker field does not provide an option to select any users.

Environment

Jira Software v8.x and above.

Diagnosis

When a user picker field is configured to be visible on the portal, non-agent customers attempting to select the user picker field will find that no action occurs. There are no prompts or options provided to input the required keyword.

  • The screenshot below illustrates the outcome when a customer (non-agent) attempts to choose the user picker field.

  • When an agent attempts to choose the user picker custom field, they will find the search option readily available. Subsequently, the agent can proceed to select users.

Cause

In the JSM Project, if the customer permission is set to not share the request with any customer, this might trigger the problem.

Solution

  1. Navigate to Admin > Projects > Affected_Project
  2. Click on "Customer Permissions"
  3. Under Who can customers share requests with? select the radio button for Any customer or organization, by searching in this project


Last modified on Jul 9, 2024

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