The user profile picture or default avatars do not load as expected across the Atlassian Cloud Site

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When trying to view users across Atlassian Cloud UI, it is possible that the user profile picture or the default avatar (User initials) is not displayed, and the default anonymous user image is seen as the icon. 

Environment

Atlassian Cloud Products

Diagnosis

The user profile picture or avatar is not visible when:

  • Checking the assignee filter in Sprint/Kanban boards (Jira)
  • Viewing all user spaces in Confluence
  • Viewing the users list on the User Administration page in admin.atlassian.com

Cause

When a web page is loaded across products in Atlassian Cloud, the external Gravatar servers are queried. It is possible that the Gravatar server has rate-limited the requesters from the Atlassian Cloud site, and hence, none or some of the user's images/avatars don't load as expected. The rate limits can be confirmed when viewing the avatar network request in the browser developer tools (network tab) or when checking the HAR file

Request URL: https://i1.wp.com/avatar-management--avatars.us-west-2.prod.public.atl-paas.net/initials/AB-5.png?ssl=1
Request Method: GET
Status Code: 429 Too Many Requests

Solution

Usually, the rate limits are temporary, and once they are lifted, the user images/avatars should start loading as expected. Atlassian does not control the rate limits for Gravatar servers since this is an external service. If you are facing the rate limits for an extended period of time, then we suggest raising a ticket with the Gravatar support team to understand why their servers are rate-limiting the requests. The parent company, "Automattic", has a portal through which tickets may be submitted: https://automattic.com/contact

Last modified on May 23, 2024

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