This form Contains a Hidden Field
Symptoms
In JIRA Service Desk, a customer portal form with the following error message is displayed when using a custom field:
This message appears regardless of which custom field is used. In our example, the custom field is Limit Requested.
The following appears in the atlassian-jira.log
:
TP-Processor101 ERROR sysadmin 7x145034x1 e8qm81 59.167.133.100,165.254.226.226 /servicedesk/customer/portal/1/create/78 [feature.customer.request.CustomerRequestValidators$] A validation failure occurred when a customer attempted to create a request with issue type 'Service Request - Other'. The hidden field 'Summary' is required and does not have a default value set.
Cause
We are looking at the field "Summary" and how it's hidden. So when creating a request without specifying a Summary, you get the error saying that the Summary is missing.
Workaround
To avoid getting this error, ensure that you specify a summary
Resolution
Add the Summary field to all the Issue Creation Screens in Service Desk. If you don't want it to be filled in by the customer, then it can be hidden with the default value: "Credit Card Request" for example.