Translated Name and Description set for a status reflects differently for users
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When using the below API call to fetch all the statuses:
https://<ursite.atlassian.net>/rest/api/3/status
If translated name and description are set for a status, the API call returns a Blank description/Default description and the default name for some users.
Environment
Jira Cloud
Diagnosis
For the status Open, consider the admin has set the translated Name and Description for the language English (United Kingdom)
Run the API call to fetch all the statuses:
https://<ursite.atlassian.net>/rest/api/3/status
Users can encounter below results:
{
"self": "https://ursite.atlassian.net/rest/api/3/status/1",
"description": "The issue is open and ready for the assignee to start work on it.",
"iconUrl": "https://ursite.atlassian.net/images/icons/statuses/open.png",
"name": "Open",
"untranslatedName": "Open",
"id": "1",
"statusCategory": {
"self": "https:/ursite.atlassian.net/rest/api/3/statuscategory/2",
"id": 2,
"key": "new",
"colorName": "blue-gray",
"name": "To Do"
}
},
The name and description fetched are the ones.
Cause
The API results are fetched according to the language set by the user under Account settings on id.atlassian.com.
Solution
Set the language under Account settings on id.atlassian.com to English (United Kingdom) and run the API call to note that the translated name and description are returned.
{
"self": "https://ursite..atlassian.net/rest/api/3/status/1",
"description": "This is open",
"iconUrl": "https://ursite.atlassian.net/images/icons/statuses/open.png",
"name": "Hello Open",
"untranslatedName": "Open",
"id": "1",
"statusCategory": {
"self": "https://ursite..atlassian.net/rest/api/3/statuscategory/2",
"id": 2,
"key": "new",
"colorName": "blue-gray",
"name": "To Do"
}
},
UI also respects the language settings to display the field's name and description based on the translation set for the language.