Troubleshooting Missing Email Notifications for User Mentions


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

In Jira Cloud, when some users mention (@ tag) other users, the mentioned users should receive an email notification about being mentioned. In some scenarios, however, this in not the case. There are 3 most likely causes we will explore in this article.

Causes

Emily mentions Robert in the Jira issue:

But Robert doesn't receive email notification.

Such scenario may occur if:

  1. Robert disabled email notifications
  2. Emails to Robert's email address got suppressed
  3. Emily doesn't have Browse users and groups global permission

Solution

As a troubleshooting measure, please make sure Robert's inbox accepts emails from other email addresses (incl. those with domains, different to Robert's). Additionally, be sure to check Spam and other inbox folders (Notifications, etc.).

Scenario 1: Robert Disabled Email Notifications

If Robert has disabled his email notifications, he won't receive any email alerts from Jira Cloud, including those for mentions. Here's how Robert can check and adjust his email notification settings:

  1. Robert should log in to the Jira Cloud site, where Emily mentioned him.

  2. Navigate to his profile picture at the top-right part of the page, click on the profile picture and select Personal Settings.

  3. Under the Email notifications for issue activity section, he should ensure Send me email notifications is selected and checkboxes under Get email updates for issue activity when: are selected appropriately.

  4. If Someone mentions you checkbox was unchecked, he should check it and click Save changes.

Scenario 2: Emails to Robert's Email Address Got Suppressed

If emails to Robert's email address got suppressed, he would not receive any emails from Jira.

In this case, please contact Atlassian Support to get Robert's email address unsuspended.

Scenario 3: Emily Doesn't Have Browse Users and Groups Global Permission

If Emily does not have the Browse Users and Groups global permission, she won't be able to trigger email notifications for Robert when she mentions him. Here's how Site Admin or Jira Admin can grant Emily the necessary permission:

  1. Log in to the Jira site in question.
  2. Choose ⚙️ > System.

  3. Click Global Permissions.

  4. Scroll to the bottom of the page to find the Add Permission section.

  5. Select the Browse Users and Groups in the Permission dropdown.

  6. In the Group drop-down list, either:

    • select the group Emily is a member of

    • select Anyone to grant permission to users who aren't logged in (not recommended)


If you wish to add Emily to a group, that already grants Browse Users and Groups global permission:

  1. Check that group's name in your Jira site under ⚙️ > System > Global Permissions.
  2. As a Site Admin, log in to your Atlassian Admin Hub and select your organization if you have more than one.

  3. Select the site's name and URL to open the Admin for that site, then select Groups (or select Directory > Groups).

  4. Select the group that you want to add users to.

  5. Select Add group members and search for the users you want to add.

  6. Select Add users.


Last modified on Apr 11, 2024

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