Unable to add Agent channel in MS Teams for JSM Chat
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Problem
When trying to connect an Agent channel in MS Teams the following error is returned from the Assist bot:
It looks like all your service projects already have private agent channels. Remove Assist from one of those channels or connect a new service project from Jira Service Management to use as an agent channel.
Possible cause
This occurs because the JSM Chat integration is trying to connect an already connected Project to this new channel as an Agent channel. If the goal is to relate a new project to this integration, see the solution below.
Solution
Initiate the process from the JSM project’s end by:
Access the JSM project.
From your service project sidebar, select Channels, then Chat, then Configure.
Select Add to Teams. This opens the Teams app store listing for Assist.
Select Add to a team.
Search for the private team you’d like to use as your agent team with Assist and select Set up bot.