Unable to Add Comments From Comment Handler Due to Invalid Permissions

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Comments are not added to issues after using the Comment Handler service. Logs contain errors like:

1 JiraQuartzScheduler_Worker-1 WARN ServiceRunner Comment Services [service.util.handler.AbstractCommentHandler] JIRA SE ADMIN does not have permission to comment on an issue in project: 10030

Cause

The comments are not added due to limited permissions.

Resolution

  1. Find the project for which this user does not have permission, by running an SQL query:

    1 SELECT * FROM project where ID = '<enter ID from WARN message>'

    This should give you the project name.

  2. In the upper-right corner of the screen, select Administration

    (Auto-migrated image: description temporarily unavailable)

    > Projects.

  3. Select a desired project.

  4. In the Project settings, go toProject Permissions

  5. Ensure that the user is in the appropriate group or role for the "Add Comment" permission.

Updated on April 8, 2025

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