Unable to add/find a field in Request Form under Request types setting
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
You are not able to add/find a field in the list of fields in the Request Form tab.
Environment
Jira Service Management Cloud
Diagnosis
When you want to add a new field to the Request form tab by navigating to:
Project settings > Request types.
Select the request type you would like to configure > Request form > Add a field.
You notice the field is not showing up in the list of fields when you attempt to add it in the Request Form tab.
Cause
Problem 1:
The affected field is not added to the Create Issue Screen.
Problem 2:
This can happen due to the fact that there is a context value defined for that field and the current Service project is excluded from it.
Solution
Solution 1:
In the Request form tab, click on Create Issue Screen and add the affected field.
Solution 2:
You need to modify the custom field's context value to include the current Service project. To edit a custom field context, perform these steps:
Select > Issues.
Under FIELDS, click Custom fields.
Find the custom field you want to configure and click > Contexts and default value. Alternatively, you can click a field's screens or contexts link and then click Contexts > Create, edit or delete contexts.
Locate the context you want to change and click Edit Configuration.
In the applicable issue types section, select or unselect the relevant issue types.
In the applicable contexts section, select or unselect the relevant projects.
Select Modify.
To learn more about configuring a custom field context, please visit Configure custom field context. Also, see Field missing on screen in Jira for other related problems.