Unable to add or invite a Jira Service Management customer

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When adding Jira Service Management customer in Customer section of service project , you get the error message "The following customers could not be added: "jira@mydomain.com" Please check the email addresses and try again."

Diagnosis

  1. Verify if the user you are trying to add as customer has Atlassian Account already from the User management page (https://<url>.atlassian.net/admin > Users)
  2. Verify if the user is already added as portal-only customer in Jira Service Management page (https://<url>.atlassian.net/admin > Jira Service Management page)


3. Verify if under customer access settings (https://<url>.atlassian.net/jira/settings/products/servicedesk/customer-access), Internal or External options are checked and also for Internal account type access that approved domains are allowed

Cause

  1. The account already exists but the access has been revoked in User Management page

            

2. The portal-only account already exists, but it is inactive.

3. Not having checked Internal nor External account type access, won't allow users to invite customers:

In case of having checked just the Internal account type access, if under your approved domains setting allows only for certain domains. It won't be possible to send invites to customers with non-approved domains, resulting in the following error message:

Solution

Problem 1:


You need to reactivate their account. If you don't plan to grant the user with the product access and not to be billed for the account, you need to turn on the toggle "Has access on site" and toggle off the rest of the products access.

Below are the steps:

  1. Navigate to User Management page > Users
  2. Under Access, check "Has access on site".
  3. Navigate back to your project > Customers > Add customers

Problem 2:

You need to reactivate their account under Jira Service Management section within User Management. 

Below are the steps:

  1. Navigate to User Management page > Jira Service Management
  2. Search for the user > click (...) > Select "Grant Access option"

Problem 3:

You need to check at least one of the current account type accesses (Internal/External or both) depending on your business needs. In case your current configuration allows only Internal customer access (Without checking External access) you must allow the customer email domain:

Below are the steps:

  1. Access the admin.atlassian.com URL page
  2. Click on Products 
  3. On the left bar click on User access settings
  4. Add the necessary domains under approved domains tab

Relevant links:



Last modified on Feb 2, 2024

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