Unable to assign tickets to Jira Service Management agent with "Issue could not be updated" error

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

You're unable to assign a ticket to Jira Service Management Agent.

Diagnosis

You see the following error when you attempt to assign the ticket to an Agent.

Issue could not be updated
The 'assignee' field of PROJ-1 could not be updated. User '<User ID>' cannot be assigned issues." 

Cause

It happens because you don't have the right permissions. 

  • To be able to assign an issue, make sure you have Assign Issues
  • To be able to be assigned with an issue, the user must have the following permissions:
    • Assignable User
    • Service Project Agent and have a Jira Service Management license

Solution

You need to check the license and the permission granted to the affected user.

Check the user license

  • Go to Settings () > User management.

  • Select a user on the Users page.

  • Under Groups, check if the user has Jira Service Management License.

Check the Permission under the service project

  • Go to Project Settings > Permissions 
    • Make sure the affected project has the Assign Issue and Assignable User
  • Click Actions > Edit permission

  • For each permission available, select the Update link to grant permission to a user, group, or role. This displays the Grant permission dialog. Read the details of each available project permission.

  • In the Update permission dialog, select who to grant the permission to and click the Update button. You can grant permissions to:


To learn more about User management and Project permission, please visit:

Last modified on Feb 2, 2024

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