Unable to assign tickets to Jira Service Management agent with "Issue could not be updated" error
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
You're unable to assign a ticket to Jira Service Management Agent.
Diagnosis
You see the following error when you attempt to assign the ticket to an Agent.
Issue could not be updated
The 'assignee' field of PROJ-1 could not be updated. User '<User ID>' cannot be assigned issues."
Cause
It happens because you don't have the right permissions.
- To be able to assign an issue, make sure you have Assign Issues
- To be able to be assigned with an issue, the user must have the following permissions:
Solution
You need to check the license and the permission granted to the affected user.
Check the user license
Go to Settings () > User management.
Select a user on the Users page.
Under Groups, check if the user has Jira Service Management License.
Check the Permission under the service project
- Go to Project Settings > Permissions
- Make sure the affected project has the Assign Issue and Assignable User
Click Actions > Edit permission
For each permission available, select the Update link to grant permission to a user, group, or role. This displays the Grant permission dialog. Read the details of each available project permission.
In the Update permission dialog, select who to grant the permission to and click the Update button. You can grant permissions to:
Individual users, which your site admin can invite to your Jira products. Learn more inviting users.
Groups, which your site admin sets up. Learn more about groups.
Project roles, which Jira administrators can set up in advance. Learn more about project roles.
Issue roles such as Reporter, Project Lead, and Current Assignee.
Anyone, which can make issues public to the internet. Learn more about anonymous access.
A (multi-)user picker custom field.
A (multi-)group picker custom field. This can either be an actual group picker custom field, or a (multi-)select-list whose values are group names.
To learn more about User management and Project permission, please visit: