Unable to authenticate against Microsoft Exchange IMAP server after upgrade JIRA

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server, Data Center, and Cloud By Request - This article was written for the Atlassian server and data center platforms but may also be useful for Atlassian Cloud customers. If completing instructions in this article would help you, please contact Atlassian Support and mention it.

Symptoms

After upgrade JIRA from 4.x to 5.2.10, JIRA failed to authenticate the IMAP incoming mail server.

The following stack traces appears in the atlassian-jira-incoming-mail.log:

DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x400x3 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG IMAP: AUTH: NTLM
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x400x3 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: protocolConnect login, host=example.example.example.net, user=mailbox@example.net, password=<non-null>
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x400x3 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG IMAP: AUTHENTICATE NTLM command trace suppressed
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x400x3 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG NTLM: type 1 message: 4E 54 4C 4D 53 53 50 00 01 00 00 00 03 A2 00 00 00 00 00 00 2C 00 00 00 0C 00 0C 00 20 00 00 00 75 6B 6C 76 61 64 64 74 6F 30 31 61
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x400x3 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG IMAP: AUTHENTICATE NTLM command result: A1 NO Logon failure: unknown user name or bad password.
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa Getting session
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa Debug messages from JavaMail session initialization will not appear in this log. These messages are sent to standard out.
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa Session providers: [[javax.mail.Provider[STORE,imap,com.sun.mail.imap.IMAPStore,Sun Microsystems, Inc], javax.mail.Provider[STORE,imaps,com.sun.mail.imap.IMAPSSLStore,Sun Microsystems, Inc], javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun Microsystems, Inc], javax.mail.Provider[TRANSPORT,smtps,com.sun.mail.smtp.SMTPSSLTransport,Sun Microsystems, Inc], javax.mail.Provider[STORE,pop3,com.sun.mail.pop3.POP3Store,Sun Microsystems, Inc], javax.mail.Provider[STORE,pop3s,com.sun.mail.pop3.POP3SSLStore,Sun Microsystems, Inc]]]
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa Session addressMap: [{rfc822=smtp}]
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: getProvider() returning javax.mail.Provider[STORE,imap,com.sun.mail.imap.IMAPStore,Sun Microsystems, Inc]
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: mail.imap.fetchsize: 16384
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: mail.imap.statuscachetimeout: 1000
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: mail.imap.appendbuffersize: -1
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: mail.imap.minidletime: 10
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: disable AUTH=PLAIN
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: trying to connect to host "example.example.example.net", port 123, isSSL false
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa * OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 (example.example.example.net) ready.
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa A0 CAPABILITY
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa * CAPABILITY IMAP4 IMAP4rev1 IDLE LOGIN-REFERRALS MAILBOX-REFERRALS NAMESPACE LITERAL+ UIDPLUS CHILDREN AUTH=NTLM
A0 OK CAPABILITY completed.
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG IMAP: AUTH: NTLM
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG: protocolConnect login, host=ukwatxmb102v.zone1.scb.net, user=mailbox.example.example.example.net, password=<non-null>
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG IMAP: AUTHENTICATE NTLM command trace suppressed
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG NTLM: type 1 message: 4E 54 4C 4D 53 53 50 00 01 00 00 00 03 A2 00 00 00 00 00 00 2C 00 00 00 0C 00 0C 00 20 00 00 00 75 6B 6C 76 61 64 64 74 6F 30 31 61
DEBUG [ukwatxmb102v] http-bio-8443-exec-4 1277484 847x430x1 71hx5a 10.194.17.172 /secure/admin/VerifyPopServerConnection!update.jspa DEBUG IMAP: AUTHENTICATE NTLM command result: A1 NO Logon failure: unknown user name or bad password.

Cause

JIRA is not able to identify the NTLM authentication properly.

Resolution

Set the following parameter in JVM System property:

-Dmail.imap.auth.plain.disable=true 
-Dmail.imap.auth.ntlm.disable=true 
-Dmail.imap.auth.gssapi.disable=true
Refer to Setting Properties and Options on Startup for more details.

Last modified on Oct 19, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.