Unable to change Jira Workflow due to migration error
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Problem
When trying to publish a workflow scheme that had a change in workflows in an active project you may receive the following error:
Possible cause
This may be occurring because the affected tickets are associated with an Issue Type that is not related to your project anymore. When you do this workflow migration, the system validates all issues and their Issue types to execute the process only in the desired ones, since some issues have inconsistent data that's why the error return.
To validate that, access the ticket and see the name of the Issue Type by hovering the mouse over the icon:
Then go to the project > Project settings > Issue type > check if the issue type is in the list.
If the Issue Type is not listed there, see the next section.
Solution
If you re-add the missing Issue Type to the project you should be able to successfully execute the workflow change.
To re-add the Issue type:
Go to the project > Project settings > Issue type > Edit issue types.
Drag and drop the desired Issue Types from the Available Issue Types to Issue Types for Current Scheme.
If the Issue Type Scheme is shared with multiple projects, this change will affect more than one project. You may want to copy the Issue Type Scheme, add the missing Issue Type and associate the Scheme with only the affected project, to not affect all projects.