Unable to change managed user details (Error: Cannot load user details)
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When navigating to the Directory > Managed accounts under the admin hub, the below error is shown:
Environment
Jira Cloud
Diagnosis
Verify that the user accessing the page is an organisation admin.
Cause
This error is shown in scenarios when the managed users are provisioned via Google Workspace, and the IDP is disconnected from the Atlassian organisation in the admin hub.
Solution
To Resolve this error, go to Security > Identity providers tab. Disconnect and reconnect the IDP and ensure that the user provisioning is enabled.