Unable to create an issue from the backlog, however, the create button at the top functions correctly.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Unable to create an issue from the backlog, however, the create button at the top functions correctly.
Environment
Cloud
Cause
When an issue is created from the backlog, it opens the "Create Issue" page, which displays the following error.
The target project doesn't exist or you don't have permissions to create issues in it.
As the error message refers to a problematic project, upon reviewing the board query associated with the project, you may see a query similar wherein the project is not scoped correctly:
project = XYZ and "Team Assignee[Select List (multiple choices)]" in (example) or component in ("A", "B", "C") ORDER BY Rank
The definition of the project scope was added without any brackets resulting in global scope.
Solution
Make use of brackets to have project scope as required. This should resolve the issue
For example:
project = XYZ and ("Team Assignee[Select List (multiple choices)]" in (example) or component in ("A", "B", "C")) ORDER BY Rank