Unable to create Jira issue using an Incoming Mail Handler because the sender of the email is anonymous

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Issues are not created when using a Jira Incoming Mail Handler of type Creating Issues and Comments from Email. The desired effect is to create issues anonymously.

Diagnosis

The Jira Incoming Mail logs show the warning below:

2023-12-28 09:52:32,698+0000 WARN [Test] Caesium-1-1 anonymous    Test Mail Handler Test Mail Handler[10100]: Sender is anonymous, no default reporter specified and creating users is set to false (or external user management is enabled). Message rejected. 

Cause

This issue is happening because of the 2 reasons below combined:

  • the sender of the email is not associated to any Jira account (= anonymous sender)
  • AND the Jira Mail Handler is not configured to properly handle this situation

For the Jira Mail Handler to create a new Jira issue from an incoming email, it needs to set a reporter for this issue. If the Mail Handler is unable to find a valid reporter for that Jira issue, it will reject the email and will not create any Jira issue.

Solution

For the Jira Mail Handler to create issues from an anonymous sender the Mail Handler should be configured with either option described below:

  • Option 1:
    • Automatically create a new Jira user using the email address of the sender and create a new Jira issue with this user as the reporter
    • To do it:
      • Edit the configuration of the Jira Mail Handler in ⚙ > System > Incoming Mail
      • Tick the option Create Users 
      • Save the Jira Mail Handler configuration
    • With such configuration, if the user creation by the mail handler is successful, you should lines like this in the Jira Incoming Mail Logs:

      2023-12-28 10:26:32,384+0000 INFO [Test] Caesium-1-4 anonymous    Test Mail Handler Test Mail Handler[10100]: Created user 'someuser@abc.com.
      2023-12-28 10:26:32,683+0000 INFO [Test] Caesium-1-4 anonymous    Test Mail Handler Test Mail Handler[10100]: Issue SCRUM-39 created
  • Option 2:
    • Create new issues using a default user as the reporter
    • To do it:
      • Edit the configuration of the Jira Mail Handler in ⚙ > System > Incoming Mail
      • In the Default Reporter field, select a user who:
        • who has Jira Application Access
        • and who has the permission to create issues in the project the Mail Handler is configured with
      • Save the Jira Mail Handler configuration
    • With such configuration, if the user creation by the mail handler is successful, you should lines like this in the Jira Incoming Mail Logs:

      2023-12-28 10:42:32,386+0000 INFO [Test] Caesium-1-2 anonymous    Test Mail Handler Test Mail Handler[10100]: Issue SCRUM-40 created
      2023-12-28 10:42:32,389+0000 INFO [Test] Caesium-1-2 anonymous    Test Mail Handler Sender(s) [someuser@abc.com] not registered in JIRA. Using configured default reporter 'defaultreporteruser'.


Last modified on Dec 28, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.