Unable to Edit the Mail Service
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
In JIRA 5.0 the Edit button no longer appears next to the Mail Service, as illustrated in the example below.

Cause
One of the features in JIRA 5.0 is a new email handler wizard. The following mail services are no longer editable within the services section as they are managed elsewhere.
com.atlassian.jira.service.services.imap.ImapService
com.atlassian.jira.service.services.pop.PopService
com.atlassian.jira.service.services.file.FileService
Resolution
To access the new Mail Handler, refer to the below instructions:
Log in as a user with the JIRA Administrators global permission.
Select Administration > System > Mail > Incoming Mail to access the Mail Handlers section of the Incoming Mail page (below the POP / IMAP Mail Servers section).
Keyboard shortcut: g + g + start typing incoming mail
ℹ️ Refer to the Configuring JIRA to Receive Email from a POP or IMAP Mail Server documentation for further information on setting up and making changes to the new Mail Handlers.
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