Unable to find the field while creating a Jira issue even though the field is added to the create issue screen
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Some Jira fields are not visible in the Create Issue screen even after configuring them correctly in the Create Issue screen configuration. The field can be found in the view screen but not while creating the issue within the same project
Environment
Jira Cloud
Cause
- The first check is to validate the Create Issue screen configuration if the fields in question are properly added in the Create Issue screen scheme associated with the Jira project.
- The next step is to check the Field configuration to validate if the field is marked as hidden which will not render the field in the issue view.
- After both these checks are done and if these checks are passed, the root cause of this issue comes from the new Create Issue modal where there is a three-dot icon on the top right part.
- On clicking the three-dot icon(...) >> Show Fields, this option lets end users customize which fields appear on the create issue experience by choosing between showing All fields or only Custom fields.
The Show fields menu is used to show the fields you are interested in from the fields added to the issue create screen. This is a user-specific setting and can't be forced globally on all users unless the field is made mandatory/required. Here is the Feature Request raised for this ask.
Solution
When our Jira users try creating a ticket, sometimes certain fields will not show up on the ticket. The fix for this is to click on the Ellipsis button (top right of the window - three dots) > Show fields > Change "Custom fields" to "All fields" and then click "Apply".
At the moment, we don't have the ability to force specific field options for users. This ability is being tracked as an Improvement request: Globally set All fields for Issue creation