Unable to find the IssueID and ParentID fields when importing parent-subtask relationships via External System Import - CSV
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Unable to find the IssueID and Parent fields when importing parent-subtask relationships via External System Import - CSV
Environment
Jira Cloud
Notes
- In this KB, the field names within Jira are IssueId and Parent. Sometimes the term ParentId is used to reference the issueId of the Parent issue. Jira Cloud doesn't have a field called ParentId by default, just Parent.
- Both of these fields use the same format of a unique numeric value to represent the specific issue in question.
- All issues in Jira will have an IssueId.
- Not all issues will have a parent. Only issues that have a parent (subtasks or child issues in an epic for examples) will have a value for the parent field
Diagnosis
While importing CSV, it was observed that we are able to import all relations except sub-task relation to parent (Issue ID and parent ID fields)
The issueid or parentid fields are not suggested in the field mapping step:
Causes
Cause 1
Sub-Tasks were turned off (disabled) when we navigate to the System> Settings> Jira Settings> Issues> Sub-Tasks
Cause 2
These field are also unavailable when using the Bulk Create link found within the Issue Navigator ... Menu > Import issues from CSV
This import option is available to all Jira users that have the create issue permission for at least one project.
Solutions
Solution 1
Enable the Sub-Tasks option while navigating to the System> Settings> Jira Settings> Issues> Sub-Tasks.
We can map the Parent ID field successfully while importing after enabling the Sub-Tasks option.
Reference Link:
- https://[yoursite].atlassian.net/secure/admin/subtasks/ManageSubTasks.jspa
Solution 2
To be able to create or edit the issue fields of "IssueId" and "Parent", you will need use the External System Import tool. Only users that have the Jira Administrator role will be able to access the
Settings > System > External System Import > CSVThis option must be used to be able to set these issue fields during an issue import.