Unable to inline edit the 'Assignee' field in the Issue View screen eventhough the 'Assign to me' button appears on screen.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

User is unable to inline edit the 'Assignee' file in the Issue View screen of a ticket. However, the 'Assign to me' button appears on the screen and users able to successfully themselves using the button. Also, they are able to see the Assign button beside More and they are able to search for users through the 'Assignee' field there.

Cause

The 'Assignee' field is not added in the 'Edit/View Issue screen' of the issue.

Resolution

Add the field to the 'Edit/View Issue screen' of the issue following the steps provided below.

  • Head to your Project Settings > Screens.

  • For any of the Issue Types, on the Operation Edit Issue, click on the screen.

  • Check if there is an 'Assignee' field on the screen. If not, please add them.

  • Repeat the same steps with the Operations View Issue screen.

  • Ensure that all 'Edit/View Issue' screen for all Issue Types has the 'Assignee' field.

Updated on April 8, 2025

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