Unable to install add-on on sandbox site.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
In the sanbox instance unable to install add-on as a site admin user. When a site admin user tries to install the add-on isn't installed. Instead it appears under manage app requests.
Environment
Cloud
Diagnosis
Searched in splunk logs using the app key and adjusted the timeframe around the time when the app was requested to be installed.
You can see the following error in the logs:
msg: 400: accessToken: unknown access token
stack: com.atlassian.marketplace.client.MpacException$ServerError: 400: accessToken: unknown access token at com.atlassian.marketplace.client.impl.ApiHelper.responseException(ApiHelper.java:240) at com.atlassian.marketplace.client.impl.ApiHelper.getOptionalEntity(ApiHelper.java:116) at com.atlassian.marketplace.client.impl.AddonsImpl.getByKey(AddonsImpl.java:57) at com.atlassian.upm.pac.PacClientImpl.lambda$getAvailablePluginInternal$5(PacClientImpl.java:241)
Cause
When customer created the sandbox and Copy data from production the App gets added automatically with Access Token.
Solution
Go to market place find the app.
Find the app Descriptor.
Copy the URL
Edit the URL and remove the -cdn from the URL.
Go the instance Manage App.
Select Upload app paste the corrected URL.
Remove the Access Token and save.
In Sandbox Access Token is not required because picking up the license for the Production.