Unable to link a form to change management
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
You are not able to link Jira Forms to Change Management as it is not listed in the dropdown in Form settings
Environment
Jira Service Management cloud
Diagnosis
By design, you will be able to locate Change Request under the Jira Forms provided that such a Request type exists (Settings > Request Form > Choose Request Form Type). If it doesn't, then it indicates that there could be some issues with the Request Type itself.
Cause
- Sometimes you/other admins might have deleted the associated Issue types from a Service Project and due to this the request type linked to that Issue type shows an Invalid Issue Type in the configuration page as shown below:
Solution
- You can re-add the removed Issue type back to the service project which will auto-associate the request types to all valid issue types.
These changes can be made by navigating to Project Settings > Issue Types > Action > Edit Issue Types > Drag and Drop relevant issue types from the "Available issue Types" box to "Issue Types for Current Scheme" > Save. - If step 1 isn't ideal for your use case then you can create a new Request Type under Project Settings > Request Types > Changes > Create Request Type using any other issue type that is still associated with the project
- Once either of the above steps is done then you can open Forms Settings (Project Settings > Forms > Select the relevant form to associate with Change Request)
Then go to Settings > Request Form > Click on Choose Request Type > Select Change Request > Save changes.