Unable to route the call to certain countries while using incoming call integration with Twilio
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
We have integrated incoming call routing with Opgenie using the Twilio number as mentioned in the below public document. However, while testing this integration the call is not getting routed to certain countries(In this scenario the Netherlands) from the Twilio account.
Diagnosis
Started analyzing Opsgenie logs and noticed the below message(Settings > Debug > Logs):-
[system] Couldn't dial 31-XXXXXXXX; reason: Code[21215]: Account not authorized to call +31XXXXXXXX. Perhaps you need to enable some international permissions: https://www.twilio.com/console/voice/calls/geo-permissions/low-risk
Cause
- As part of the Voice Geographic Permissions on Twilio, the specific country needs to be enabled to perform the outgoing calls as mentioned in this document:- https://www.twilio.com/docs/sip-trunking/voice-dialing-geographic-permissions
Solution
- Verify and Enable the country where the call has to be routed according to the requirement.