Unable to search few users in user picker (single user) custom field
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
This article mentions the scenario when a User Picker (single user) custom field is being used and only a specific set of users are displayed in the custom field.
Environment
Jira Cloud
Diagnosis
The users in the User Picker (single user) custom field can be restricted from being displayed/searched based on two criteria:
- The global permission to 'Browse Users and Groups' (This would only be applicable if none of the users are visible in the custom field and the user is also unable to browse users anywhere else in the issues such as '@ mentions' in comments, or updating the assignee)
- User Filtering is configured in the context of the User Picker (single user) custom field.
Solution
- The users displayed in a user picker (single user) custom field can be restricted if the user filtering is configured with a specific set of group(s).
In order to validate this: Select > Issues.
Under FIELDS, click Custom fields.
Find the User Picker (single user) custom field and click > Contexts and default value > Edit User Filtering.
NOTE: This option is only available for custom field types containing User picker (single user), not User picker (multiple user).
Modify the groups and roles that have users whom you want to be displayed in the user picker custom field.
The user picker will only show users that are in the groups and roles selected.
Click Save.