Unable to search knowledge based article even though the article exists
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Occasionally a confluence knowledge base article/page is not found to be displayable and/or searchable, when it should be as it is linked and searchable from the associated Jira Service Management project. Other pages from the linked KB space are visible and searchable however.
Environment
Cloud.
Diagnosis
This is because there can sometimes be bad characters in the page title (in place of white space characters) which are not obvious nor easily visible to spot without use of a third party text editor tool.
Cause
Unknown
Solution
Edit the title of the confluence page simply by replacing each space in the title with another space character in its place, and Save.
The steps to do this are as follows:
- Go to the linked source Knowledge Base space containing the article that's not searchable from the JSM project or the portal
- Manually Search for the problematic article
- Edit the title by replacing each space in the title with another whitespace character in its place
- Save changes to the title
- Go back to the JSM project and retry finding the article by using the text box search.