Unable to search using a custom field when executing a JQL and the field can only be used to sort

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Executing a JQL search query returns an error indicating the custom field cannot be searched, only sorted.

Diagnosis

The search fails to execute and returns the error "Field 'xyz' is not searchable, it is only sortable.":

Certain custom fields may return a permission error when the search template is set to None. An example of this is the short text custom field, which returns a permission error:

"Field 'xyz [Short text]' does not exist or you do not have permission to view it."

Cause

This can happen if the search template for the custom field is set to None.

Solution

  1. Click on the icon in the upper right corner > Issues

  2. Select Custom fields under the Fields section

  3. Search for the impacted custom field and update the Search Template to the available search template
  4. Once the search template has been updated, the JQL should be executed successfully



Last modified on Dec 15, 2023

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