Unable to set issues to Resolved using the Simplified Workflow

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Symptoms

Issues being dragged to Done status in the Active sprints in a board are left with an Unresolved Resolution field status.

Cause

This was caused by a known issue tracked under  GHS-5741 - Getting issue details... STATUS If a project was created and later converted to Simplified Workflow, the Resolution field is not configured. This will lead to all Issues having a Resolution of Unresolved.

(info) If the project was created directly from JIRA Software Getting Started page, it will already use the Simplified Workflow, and the workflow will already handle setting of the Resolved status when issues are moved to the last column.

Resolution

Upgrade to JIRA Agile (now JIRA Software) 6.2.5 or higher, as GHS-5741 - Getting issue details... STATUS has now been fixed. If you are unable to upgrade the version of JIRA Software, follow the workaround below.

Workaround

Method 1 - This workaround will configure a transition screen where the Resolution field is manually set by the user:

  1. (Download/Behind-the-Firewall ONLY): Backup your JIRA Software instance (Administration > Backup data to XML).
  2. Go to workflow configuration in Administration > Issues > Workflows
  3. Edit the workflow (this will create a draft of it) and click on the Resolved Global Transition:
     
  4. Click on the Post Functions tab:
  5. Delete the post function that is set to clear the Resolution field for the Global Transitions:
  6. Edit the transition, as below:
  7. Set a Transition View. The Resolve Issue Screen will let you specify the resolution when this transition is used.
  8. After updating the screen, publish the draft of the workflow - this will migrate all your issues from the old to the new workflow. Ensure to save a backup copy!
     
  9. Repeat steps 3-8 for the Closed Global Transition.
  10. When moving an issue from a column to Done now has a transition screen where the Resolution field can be set by the user:

Method 2 - This workaround will automatically set the Resolution field to Fixed:

Click here to expand...
  1. Go to workflow configuration in Administration > Issues > Workflows
    1.1 Make a copy of the problem workflow and click on 'Edit' to edit the Resolved and Closed transitions (The reason to make a copy of the workflow is to prevent you losing current data. You will be able to rollback your current instance if any wrong steps taken.)

    1.2. Remove the post function that is set to clear the Resolution field for both Resolved and Closed transition..
    1.3 Add a post function that will set the Resolution field to Fixed(using the post function 'Update Issue Field'):

    For Transition 'Resolved':

    For Transition 'Closed':

2. When moving an issue from a column to Done now will automatically set the Resolution field to Fixed, as configured in the post function.

 3. Associate with the related Workflow Schemes and projects. See Configuring workflow schemes.

 

(info) There may be other transitions in the workflow that has a similar post function set to clear the Resolution. To resolve this; Remove the post function that is set to clear the Resolution field from any other transitions.

Additional Information

In case this KB does not fix the problem, please feel free to contact our support via https://support.atlassian.com by creating an issue with an XML backup of your database (Administration > Backup data to XML) so that we can try to reproduce the problem here for further investigate.

Last modified on Feb 26, 2016

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