Unable to update a Service Management Report Series

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Symptoms

Despite being able to see the field option while filling the filter, trying to Add/Update a Report Series will show the error:

"The option <field_option> for field <field> does not exist." 


A similar error pops up on the Browser Console:

PUT https://instance.atlassian.net/rest/servicedesk/reports/1/servicedesk/PTN/report/42/validate?timescaleId=2 400 ()


Additionally, it will not be possible to delete any Series that's currently filtering by the wrong field option

Cause

The field option has been renamed at a certain moment.

Resolution

  1. Go to Custom Fields and look for the problematic field option.
  2. Rename it to the former name (reported by the error message).


Optional:

  1. After renaming the field option back to original, delete any report series that use this field.
  2. Rename the field option to the name you want.
  3. Finally, recreate all the report series
Last modified on Nov 6, 2024

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