Unable to update the Team through Advanced Roadmaps Plan

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

When trying to update the Team trough an Advanced Roadmap (formerly Portfolio) Plan, Jira reports the operation was successful but the Plan's reloaded without the Team.


Environment

All versions of Jira Software 7.x and 8.x.

Advanced Roadmaps up to 3.29.6.


Diagnosis

  • Updating the Team through the Plan shows a success message but the Plan's reloaded with a blank Team
  • Opening the issue in Jira shows no Team has been updated (if the Team field is present the screen)
  • There are more than a Team type custom field present in Jira with context other than Global:

    select cf.id as "Custom Field ID", cf.cfname as "Custom Field Name", p.pkey as "Context Project", it.pname as "Context Issue Type"
    from customfield cf
    left join configurationcontext cc on cc.customfield = 'customfield_' || cf.id
    left join project p on p.id = cc.project
    left join fieldconfigschemeissuetype fcsit on fcsit.fieldconfiguration = cc.fieldconfigscheme
    left join issuetype it on it.id = fcsit.issuetype
    where cf.customfieldtypekey = 'com.atlassian.teams:rm-teams-custom-field-team';

    If there's any value in columns "Context Project" or "Context Issue Type", it's an issue.


Cause

Advanced Roadmaps works with the Team custom field type, and it expects theres only one custom field. If there are several custom fields of type Team, Advanced Roadmaps will try to update them all together — and if one of them has a restrictive context, it'll fail silently (providing a success message).

This issue's been mapped in:

JPOSERVER-2979 - Getting issue details... STATUS


Solution

All custom fields of type Team should be available to the project. This means we should either:

  • Delete all Team type custom fields, leaving only the locked Advanced Roadmaps generated Team field
  • Make all Team type custom fields have a global context configuration

Note that having more than one Team type custom field will make Advanced Roadmaps update all of them when the Team value changes. Ideally, there should only be one Team type custom field to avoid confusion.

Last modified on Apr 23, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.