Unable to upload CSV file for Assets Import.
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Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
This knowledge base article describes a scenario when user try to upload the file for Asset CSV import, user receives a pop-up with error message An unexpected error occurred when uploading the file.
Environment
JSM 4.x, 5.x
Diagnosis
- If we analyse har report we find that it doesn't took much time in Waiting for server response. But most of time is used in sending request, appears that user has a slow network connection.
- Problem can also be reproduced if we Simulate a slower network connection.
Solution
- First ensure that file size is well within Asset Configuration Maximum File upload size.
- If csv file is large in size and user's network bandwidth is slow, it would certainly take time to upload file successfully.
- Try with network having better speed.
- Workaround for network with slow speed is to change AJAX timeout as per How to change the default AJAX timeout in Jira server.