Unable to View Dashboard 'UrlPortMismatchException' Due to Apache Tomcat Connector

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Symptoms

Users trying to access the dashboard will encounter a System Error page containing an exception like the following:

com.atlassian.gadgets.dashboard.internal.diagnostics.UrlPortMismatchException: Detected URL port, 'XXXX', does not match expected port, '80'
at com.atlassian.gadgets.dashboard.internal.diagnostics.Diagnostics.checkExpectedPort(Diagnostics.java:81)
at com.atlassian.gadgets.dashboard.internal.diagnostics.Diagnostics.check(Diagnostics.java:32)
at com.atlassian.gadgets.dashboard.internal.diagnostics.DiagnosticsServlet.executeDiagnostics(DiagnosticsServlet.java:92)
at com.atlassian.gadgets.dashboard.internal.diagnostics.DiagnosticsServlet.doPost(DiagnosticsServlet.java:61)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
...

Cause

The most common cause of this is the use of a reverse-proxy HTTP server (often Apache or IIS) in front of the application server running JIRA. The front-end proxy is misdirecting traffic to the wrong port.

Resolution

Append proxyName="mycompany.com" and proxyPort="80" to your Tomcat connector (located in conf/server.xml). For example:

<Connector port="XXXX"
      ...........
      proxyName="mycompany.com" 
	  proxyPort="80"
      />

(info) Note that the connector may appear across multiple lines or may be on a single line.

Last modified on Apr 19, 2017

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