Unable to view worklog information of a Jira project issue via API
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When using the Jira issue search API endpoint with the "fields=worklog" parameter, we may notice that the project issues are not showing worklog information in the API response. The response may be visible in other projects in the instance.
Example:
https://instancename.atlassian.net/rest/api/3/search?fields=worklog&jql=project%20=%20Test
Environment
Jira Cloud
Diagnosis
- The worklog information is visible in the Jira issue view
- The Log work permission is granted to the user running the query
- The user is able to create new worklog entries on the project issues
Cause
The "Log Work" field is hidden in the project's field configuration. Due to this configuration, the API response does not include any worklog field information.
Solution
To view the worklog information via API, please ensure that the "Log work" field is not hidden in the field configuration. This can be changed by navigating to:
Open Project > Project settings > Field configuration > Edit (pencil icon) > Search for the field "Log work" > Click on "Show" to unhide the field
Note: A field configuration maybe shared with multiple projects and hence if the field is hidden in particular field configuration, then the API response for all issues with projects associated with this field configuration may showcase similar behaviour.