"Unexpected error" after installing or upgrading Jira Service Management
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Trying to upgrade or install JIRA Service Management using the obr by going through Administration > Versions & licenses > Upload an application. It is unable to be successfully uploaded/upgraded, and the error notification on the admin console says "An unexpected error occurred. Refer to the logs for more information.
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Diagnosis
In $JIRAHOME/log/atlassian-jira.log we have the following message:
2018-01-19 10:04:58,334 UpmAsynchronousTaskManager:thread-4 INFO USERNAME 604x1441x1 tulz7m 10.X.X.XX /rest/plugins/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] No plugins found to be installed{co
Run the following SQL Query:
select * from pluginstate;
Locate the com.atlassian.servicedesk plugin entries. Check If their pluginenable are set as false.
Cause
JSM-related plugins are already installed but disabled in the database.
Solution
Follow the Resolution steps from the article: